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1 Introduction 
Geofabric Surface Network is intended to be used in stream flow tracing operations, 
thus utilising the product’s full topological connection. The product can support the 
spatial selection of associated hydrological features (such as water bodies and 
catchments) as inputs for spatial analysis/modelling. 

This tutorial describes the steps required to create a subset of the Geofabric Surface 
Network product which retains topological relationships and can be used with tooling 
available in the standard ArcMap Water Utility Analyst toolbar (ArcGIS Desktop 9.3). An 
example of performing a simple network trace is also provided. 

In Version 2.0 of the Geofabric, geometric networks have been built and are provided 
as a component of Geofabric products. To select a subset of geofabric data, or to 
include your own Nodes in the network, a geometric network needs to be rebuilt to 
continue to utilise the products topological connectivity. 

Note: At the time of writing, a pre-canned version of Geofabric V2.0 products sub-
divided at a drainage division level is planned for release during 2012.  

 

 

November 2011| Geofabric Version 2.0 5  



Australian Hydrological Geospatial Fabric (Geofabric) Tutorial – Creating a subset of 
Geofabric data 
 
2 Tutorial 

1 Download the Geofabric Surface Network File Geodatabase from 
the Geofabric ftp site 

1.1 From the Bureau of Meteorology Geofabric website browse to Downloads and select 
Download the Geofabric data from the Geofabric FTP site. Select Geofabric Surface 
Network’s SH_Network.zip file and save this to disk 

 

 
 
1.2 Unzip the downloaded file, making sure that the resulting folder ends with .gdb (e.g. 

the contents of the file SH_Network.zip should be unzipped to a folder called 
SH_Network.gdb). 
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2 Create a Geofabric Surface Network File Geodatabase structure to 
store subset data.   

2.1 Start ArcCatalog and navigate to SH_Network.gdb that was downloaded and unzipped 
in step 1. 

2.2 Right click SH_Network.gdb > Export > XML Workspace Document 

 

2.3 Select Schema Only, check Export Metadata and Specify the output XML file: e.g. 
SH_Network_Schema.xml, Choose [Next>], Choose [Include All], Choose [Finish]. 

     

2.4 In ArcCatalog create a New > File Geodatabase (FGDB) in your chosen directory and 
rename, e.g. SH_Network_MurrayDarling.gdb 

2.5 Right click SH_Network_MurrayDarling.gdb Import > XML Workspace Document  
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2.6 In the XML Workspace Document Wizard, select Schema Only, specifying the XML 
source to import as SH_Network_Schema.xml as created in step 2.3. Choose [Next>], 
then choose [Finish]. 

    

2.7 Open the new feature dataset SH_Network, and Delete SH_Network_Net 

    

2.8 Close ArcCatalog 
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3 Create a subset of the Geofabric Surface Network File 
Geodatabase 

3.1 Start ArcMap and add in the AHGFNetworkStream, AHGFNetworkNode, 
AHGFCatchment and AHGFWaterbody feature classes from the data that was 
downloaded in step 1. 

3.2 Select a subset of AHGFCatchment features, either manually, through flow tracing or 
by undertaking a Select by Location operation with your own spatial features (e.g. a 
Catchment Management Authority reporting region) or with selected Geofabric Surface 
Catchment NCBLevel1DrainageDivision or NCBLevel2DrainageBasinGroup features.  
IMPORTANT: Due to artefacts of the stream feature derivation process used to create 
the features in the AHGFNetworkStream feature class, some stream features will 
slightly overlap the boundaries of features in NCBLevel1DrainageDivision and 
NCBLevel2DrainageBasinGroup feature classes. The same is likely when generating 
stream feature selection sets based on a spatial intersection with your own features. 
Therefore, if full stream connectivity needs to be preserved, it is strongly advised to 
follow the methodology described below when subset Geofabric Surface Network 
features with Geofabric Surface Catchment features. When subsetting Geofabric 
Surface Network with your own spatial boundary features, it is recommended that you 
utilise stream tracing when creating the feature selection sets for exporting. The same 
advice is also relevant when subsetting the stream features (AHGFMappedStream and 
AHGFMappedNode) contained within Geofabric Surface Cartography. 

3.3 In this example we will select the Murray–Darling using the Geofabric Surface 
Catchment feature class NCBLevel1DrainageDivision. Add in the 
NCBLevel1DrainageDivision feature class and select 1 record where Division = 
‘Murray–Darling’ 
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3.4 Click the Selection Menu > Select By location, and in the Select by Location Wizard, 
select features from, AHGFCatchment, that: are within (Clemantini), the features in 
this layer: NCBLevel1DrainageDivision, Use selected features, and choose [OK]. 

 

3.5 In the Table of Contents (TOC) right click AHGFCatchment > Data >Export Data, and 
in the Export Data Wizard select Selected features into your newly created FGDB, e.g. 
SH_Network_MurrayDarling.gdb\AHGFCatchment_Temp 

3.6 Open Attribute Table of AHGFCatchment which contains the selected features, and 
Choose Show [Selected]. 
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3.7 Choose Options > Related_Tables > CatchmentDrainsToSegment : is drained by to 
select all topologically related Network Streams 

 

3.8 The Table Attributes of AHGFNetworkStream is returned with related records selected. 
Choose Show [Selected], and in the TOC right click AHGFNetworkStream > Data 
>Export Data, and in the Export Data Wizard, select Selected features into your FGDB, 
e.g. SH_Network_MurrayDarling.gdb\AHGFNetworkStream_Temp 

3.9 Back to the table Selected Attributes of AHGFCatchment, Choose Options > 
Related_Tables > NetNodeDrainsCatchment : is drained by to select all topologically 
related Network Nodes. 
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3.10 The table Attributes of AHGFNetworkNode is returned with related records selected. 

Choose Show [Selected], and back in the TOC right click AHGFNetworkNode > Data 
>Export Data. In the Export Data Wizard, select Selected features into your FGDB, e.g. 
SH_Network_MurrayDarling.gdb\AHGFNetworkNode_Temp 

3.11 Make sure AHGFCatchment features are still selected. Click the Selection Menu > 
Select By location, and in the Select by Location Wizard, select features from, 
AHGFWaterbody, that: intersect, the features in this layer: AHGFCatchment, Use 
selected features, and Choose [OK]. 

3.12 In the TOC right click AHGFWaterbody > Data >Export Data, and in the Export Data 
Wizard, select Selected features into your FGDB, e.g. 
SH_Network_MurrayDarling.gdb\AHGFWaterbody_Temp 

3.13 Save your ArcMap document and exit, thereby removing any potential table locks when 
working in ArcCatalog. 

3.14 Open ArcCatalog and navigate to the SH_Network feature dataset within the file 
geodatabase SH_Network_MurrayDarling.gdb created in step 2. 

3.15 Right click AHGFCatchments > Load > Load Data. 
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3.16 In the Simple Data Loader Wizard: 
3.16.1 Choose [Next>]. 
3.16.2 For Input data, select AHGFCatchment_Temp as created in step 3.5, Choose [Add] 

then [Next>]. 
3.16.3 Take default I do not want to load all features into a subtype, choose [Next>]. 
3.16.4 Accept default Target Field  / Matching Source Field  mappings, Choose [Next>] 
 

   
 
3.16.5 Select Load all of the source data. Choose [Next>] and then [Finish]. 
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3.17 Using the Simple Data Loader Wizard, Load Data into the remaining 3 feature classes 
within the SH_Network feature dataset, these being AHGFNetworkStream, 
AHGFNetworkNode and AHGFWaterbody using the AHGF<Feature Class Name>_Temp 
files created in steps 3.8, 3.10 and 3.12. 
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4 Build a Geometric Network 
4.1 In ArcCatalog navigate to the File Geodatabase created in step 2. 
 
4.2 Open the file geodatabase, right-click on the SH_Network_MurrayDarling feature 

dataset and choose New>Geometric Network…. 
 

 
 
4.3 In the Build Geometric Network Wizard: 
 
4.3.1 Choose [Next>]. 
 
4.3.2 Choose Build a geometric network from existing features for the question How do 

you want to build your geometric network?; Click [Next>]. 
 
4.3.3 Click to add a check-mark to the AHGFNetworkNode and AHGFNetworkStream 

feature classes and leave the network name as the default (e.g. SH_Network_Net); 
Click [Next>]. 
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4.3.4 Choose Yes for the question Do you want to preserve existing enabled attribute 

values?; Click [Next>]. 
 
4.3.5 Choose Yes as the response for Do you want complex edges in your network? and 

ensure that AHGFNetworkStream has a check-mark next to it. Click [Next>]. 
 
4.3.6 Choose No for Do your features need to be snapped?; Click [Next>]. 
 
4.3.7 Choose No for Does your network have sources and sinks?; Click [Next>]. 
 
4.3.8 Choose No for Do you want to assign weights to your network?; Click [Next>]. 
 
4.3.9 Click [Finish] and when the network has finished being built there will be a geometric 

network object (e.g. SH_Network_Net) and a Junctions feature class (e.g. 
SH_Network_Net_Junctions) added to the SH_Network feature dataset. The 
Junctions feature class is automatically generated when a geometric network is 
created, but in this case it will be empty and can be ignored. 
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5 Set the flow direction of the network 
 
5.1 Download the ‘Set Flow by Digitized Direction Command’ from the ESRI Developer 

Network ArcObjects Online website. 
 
5.2 Unzip the contents of the downloaded zip file (SetFlowByDigitizedDirection.zip) to an 

appropriate directory. 
 
5.3 Start ArcMap and add in the geometric network created above (SH_Network_Net). 
 
5.4 Add the Utility Network Analyst toolbar (View>Toolbars>Utility Network Analyst). 
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5.5 Click on Tools>Customize and select the MyFlowDirectionSolver.dll using the [Add 

From File] button on the customization dialogue (the following message should be 
displayed). 

 

 
 
5.6 Click on the Commands tab of the Customize dialogue, choose the Developer Samples 

commands category and add (drag-and-drop) the Set Flow by Digitized Direction 
command to the Utility Network Analyst toolbar. 

 

 
 
5.7 Choose Toolbars from the View menu and add in the Editor toolbar (if necessary) and 

start editing (Editor>Start Editing), Selecting SH_Network_MurrayDarling.gdb as the 
source database to edit data from 

 

5.8 Click on the newly added tool ( ) to set the flow direction according to the digitized 
direction of the features.  

 
5.9 Save your edits and finish the edit session (Editor>Save Edits; Editor>Stop Editing). 
 
5.10 Zoom to an area of interest. 
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5.11 From the Utility Network Analyst toolbar, choose Flow>Display Arrows ( ) to turn on 
flow direction arrows. An arrow should display to indicate that the flow direction has 
been correctly set. 
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6 Trace upstream from a node in the network 
6.1 In ArcMap, Zoom to an area of interest. 
 

6.2 From the Utility Network Analyst toolbar, choose the Add Junction Flag Tool ( ) and 
click on a feature from the AHGFNetworkNode feature class to add a flag for network 
tracing (green box in figure below). 

 
 

 
 
6.3 Choose Trace Upstream from the Trace Task: menu on the Utility Network Analyst 

toolbar. 
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6.4 Click on the Solve button ( ) on the Utility Network Analyst toolbar in order to 
perform the network trace. By default, the results of the trace operation will be 
displayed as red coloured drawing objects (this can be changed in Analysis > Options… 
on the Utility Network Analyst toolbar). Similarly, if you wish to select features instead 
of displaying as a different colour, this can also be changed in Analysis > Options 
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Through the Water Act 2007, the Australian Government has given the Bureau of 
Meteorology responsibility for compiling and delivering comprehensive water 
information across Australia. 

For more information 
Visit our website at www.bom.gov.au/water 
Send an email request to waterinfo@bom.gov.au 
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